Willkommen auf unserer neuen Forenplattform für das Bus-Profi Forum

Neue Felder für die persönlichen Daten
Man kann jetzt seine öffentlich einsehbare Daten genau bestimmen. Details findet ihr in in diesem Beitrag.

Durch die neue Forensoftware und die Portierung der Daten konnten die Passwörter aus dem alten Forum nicht übernommen werden, bitte lassen Sie sich ein neues Passwort über die Passwort vergessen Funktion zusenden. Sollte es zu Problemen kommen kontaktieren Sie das Bus-Profi Team per E-Mail.

i-port Lichtsensor eigenbau

... alles was es nicht bei Issendorff gibt

Nolte
Fingerwundschreiber
Fingerwundschreiber
Beiträge: 211
Registriert: Do 22. Mär 2007, 22:24

#61 RE: i-port Lichtsensor eigenbau

Beitragvon Nolte » Mo 5. Mai 2008, 18:52

Hallo Ima,

Achso, also ich hab von der Platine 3 Adern rausgehen lassen und dann auf den LCN-IV geklemmt.

Wie schon beschrieben, LED zum Testen perfekt. Ich hab noch die Steckbrücke dazwischen gelötet und im Betrieb ist die Steckbrücke offen.

Das ist sowas von "geil" das Teil, wenn man das mal so ausdrücken darf. Im Moment das ultimative Spielzeug. Taschenlampe und Lichtsensor. *lach*

Was hält die Allgemeinheit von einem "Umbau" zu Rauchmelder usw. ???

Gruß NOLTE

Benutzeravatar

Uwe
...
Beiträge: 14135
Registriert: So 26. Mai 2002, 23:10
Hat sich bedankt: 12 Mal
Danksagung erhalten: 25 Mal
Kontaktdaten:

#62 RE: i-port Lichtsensor eigenbau

Beitragvon Uwe » Mo 5. Mai 2008, 20:05

Dafür braucht dein altes UPP wohl aber auch mehr Strom, Thomas (da waren die Netzteile noch etwas kräftiger) ;-)

BTW: ich würde LSIZ (Lichtsensor-Iport-Zähler) bevorzugen :)

und dann hänge ich mal an ...

Plan von Thomas (I-Port Lichsensor.JPG)
Plan und Platinenlayout von Markus (LS.gif und LS-L.gif)

und viele Grüße
Uwe
Dateianhänge
131444LS-L.gif
131444LS-L.gif (9.85 KiB) 247 mal betrachtet
131443LS-L.gif
131443LS-L.gif (9.85 KiB) 247 mal betrachtet
131442LS.gif
131442LS.gif (5.18 KiB) 247 mal betrachtet
131441I-Port Lichsensor.JPG
131441I-Port Lichsensor.JPG (44.09 KiB) 247 mal betrachtet
----------------o00o----'(_)'----o00o---------------------

Benutzeravatar

Themenersteller
Thomas
Alleswisser
Alleswisser
Beiträge: 5699
Registriert: Mo 21. Apr 2008, 20:03
Hat sich bedankt: 16 Mal
Danksagung erhalten: 10 Mal
Kontaktdaten:

#63 RE: i-port Lichtsensor eigenbau

Beitragvon Thomas » Mo 5. Mai 2008, 21:54

hi,

so, mal programm fürs aussenlicht.
am upp der der eigenbau lichtsensor ( mit klebeband etwas abgedeckt) angeschlossen, ausgang vom upp ist nur test.
am sh hangt :ausgang1 treppenhauslicht(hatt noch nichts mit lichtsensor zu tun) und am ausgang2 hängt meine aussenbelechtung, gesteuert vom upp und der lcn-uhr(6:00 - 8:00 ein und 16:00 - 23:59 ein, rest gespeert)
vom sh-modul dran.

(bitte zeigt mir die fehler ) :

Mod 10 Sn: 0C03xxx I Name: UPP Lichtsensor ?
Mod 20 Sn: 0C05xxx I Name: SH+ ?

ID: 10 UPP Lichtsensor
Typ: LCN-UP+ Modul v2 Laufzeitinfo: (ausgelesen am: 05.05.2008 20:36:51)

T-Anschluss: LCN-T8/-TU4x konv. Taster
Einfach-Bedienung
Kontakte: Schließer
Tastensperrung Tabelle A zugelassen
Lang-Drück Erkennungszeit: Lang
keine DSI-Ausgabe
I-Anschluss: Impulszähler, Kein Temperatur Sensor angeschlossen
Impulszähler zählt alle Flanken
P-Anschluss: virtuelle Relais
Ausgang: Doppelschalter (bei 15%)
Verhalten: Piepen bei Tastendruck
Piepen bei Fehler
Statusmeldungen werden gesendet
Meldungen lokal (nicht global)
Meldezeit normal (nicht sofort)
Stromausfallerkennung Taste D8 kurz, >1min: lang
Statuskommandos:
Keine Statuskommandos
Schwellwerte: Hysterese: 1 B1: 1 B2: 3 B3: 44 B4: 6 B5: 15 Quelle: T-Port-SensorT-Port-Sensor
Regler 1: (keine Reglereinstellung)
Regler 2: (keine Reglereinstellung)
Tastenbelegung:
Tabelle A:
Taste A7
(1) -> Segment 0, Modul 10 "UPP Lichtsensor"
Kurz: Relais ---- ---1
Lang: Unprogrammiert
Los: Unprogrammiert
Taste A8
(1) -> Segment 0, Modul 10 "UPP Lichtsensor"
Kurz: Nullstellen
Lang: Unprogrammiert
Los: Unprogrammiert
(2) -> Segment 0, Modul 10 "UPP Lichtsensor"
Kurz: Wiederhole Summen: --3-
Lang: Unprogrammiert
Los: Unprogrammiert
Tabelle B:
Taste B1
(1) -> Segment 0, Modul 10 "UPP Lichtsensor"
Kurz: Unprogrammiert
Lang: Tabelle A Taste -------8 in 4s
Los: Unprogrammiert
(2) -> Segment 0, Modul 10 "UPP Lichtsensor"
Kurz: Unprogrammiert
Lang: Relais 10-0 0-1-
Los: Relais ---- ---0
Taste B2
(1) -> Segment 0, Modul 20 "SH+"
Kurz: Unprogrammiert
Lang: Unprogrammiert
Los: Unprogrammiert
(2) -> Segment 0, Modul 10 "UPP Lichtsensor"
Kurz: Unprogrammiert
Lang: Relais 01-0 0-01
Los: Wiederhole Summen: --3-
Taste B3
(1) -> Segment 0, Modul 10 "UPP Lichtsensor"
Kurz: Unprogrammiert
Lang: Nullstellen
Los: Unprogrammiert
(2) -> Segment 0, Modul 10 "UPP Lichtsensor"
Kurz: Unprogrammiert
Lang: Relais --U- ----
Los: Unprogrammiert
Taste B4
(1) -> Segment 0, Modul 20 "SH+"
Kurz: Unprogrammiert
Lang: Ausg.2: AUS, Rampe: 10.00 Sek
Los: Unprogrammiert
(2) -> Segment 0, Modul 10 "UPP Lichtsensor"
Kurz: Unprogrammiert
Lang: Relais 00-1 0--0
Los: Unprogrammiert
Taste B5
(2) -> Segment 0, Modul 10 "UPP Lichtsensor"
Kurz: Unprogrammiert
Lang: Relais 00-0 1-0-
Los: Unprogrammiert
Tabelle C:
Taste C3
(1) -> Segment 0, Modul 20 "SH+" (Statuskommandos Summe 3;)
Kurz: Ausg.2: EIN, Rampe: 120.00 Sek
Lang: Unprogrammiert
Los: Ausg.2: AUS, Rampe: 300.00 Sek
(2) -> Segment 0, Modul 10 "UPP Lichtsensor" (Statuskommandos Summe 3;)
Kurz: Ausg.1: EIN, Rampe: 120.00 Sek
Lang: Ausg.1: AUS, Rampe: 10.00 Sek
Los: Ausg.1: AUS, Rampe: 300.00 Sek
Tabelle D:
Taste D1
(1) -> Segment 0, Modul 10 "UPP Lichtsensor"
Kurz: Wiederhole Summen: --3-
Lang: Unprogrammiert
Los: Unprogrammiert
Taste D8
(2) -> Segment 0, Modul 10 "UPP Lichtsensor"
Kurz: Nullstellen
Lang: Nullstellen
Los: Unprogrammiert
Tableaulampen:
Lämpchen
Lämpchen 01:
Quelle: Segment 0, Modul 10, Relais 7
Aus: Lämpchen aus
An: Lämpchen ein
Lämpchen 02:
Quelle: Segment 0, Modul 10, Relais 8
Aus: Lämpchen ein
An: Lämpchen aus

Lämpchen-Summen:
Summe 3 (Taste C3): Lämpchen 1-2 Überprüft auf Status: EIN

Periodischer Zeitgeber:
Sendet Tabelle D, Taste 1 alle 150.0 s



ID: 20 SH+
Typ: LCN-SH+ Modul Laufzeitinfo: (ausgelesen am: 05.05.2008 20:40:04)

T-Anschluss: LCN-T8/-TU4x konv. Taster
Einfach-Bedienung
Kontakte: Schließer
Tastensperrung Tabelle A verboten
Lang-Drück Erkennungszeit: Lang
keine DSI-Ausgabe
I-Anschluss: Kein Sensor, Kein Temperatur Sensor angeschlossen
P-Anschluss: Kein Sensor angeschlossen
Ausgang: SW1 = Dimmer, SW2 = Schalter
Verhalten: Kein Piepen bei Tastendruck
Kein Piepen bei Fehler
Statusmeldungen werden gesendet
Alle Ausgänge global melden
Meldezeit normal (nicht sofort)
keine Stromausfallerkennung
Statuskommandos:
Keine Statuskommandos
Schwellwerte: Hysterese: 1 B1: 600 B2: 800 B3: 1600 B4: 2398 B5: Quelle: T-Port-SensorT-Port-Sensor
2400
Regler 1: (keine Reglereinstellung)
Regler 2: (keine Reglereinstellung)
Tastenbelegung:
Tabelle A:
Taste A1
(1) -> Segment 0, Modul 20 "SH+"
Kurz: Ausg.1: TrHs 120 Sek Abschaltrampe schnell
Lang: Ausg.1: UMschalten, Rampe: 1.00 Sek
Los: Unprogrammiert
Taste A2
(1) -> Segment 0, Modul 20 "SH+"
Kurz: Unprogrammiert
Lang: Unprogrammiert
Los: Unprogrammiert
Tabelle B:
Taste B1

(1) -> Segment 0, Modul 20 "SH+"
Kurz: Unprogrammiert
Lang: Sperre Ausg. total -2- für 1s
Los: Unprogrammiert
Taste B2
(1) -> Segment 0, Modul 20 "SH+"
Kurz: Unprogrammiert
Lang: Sperre Ausg. total-2- für 1d
Los: Unprogrammiert
Taste B3
(1) -> Segment 0, Modul 20 "SH+"
Kurz: Unprogrammiert
Lang: Sperre Ausg. total -2- für 1s
Los: Unprogrammiert
Taste B4
(1) -> Segment 0, Modul 20 "SH+"
Kurz: Unprogrammiert
Lang: Sperre Ausg. total-2- für 1d
Los: Unprogrammiert
Taste B5
(1) -> Segment 0, Modul 20 "SH+"
Kurz: Unprogrammiert
Lang: Nullstellen
Los: Unprogrammiert
Tabelle C:
nicht belegt
Tabelle D:
Taste D1
(1) -> Segment 0, Modul 20 "SH+"
Kurz: Addiere 1
Lang: Unprogrammiert
Los: Unprogrammiert
Tableaulampen:
keine Lämpchensteuerung
Periodischer Zeitgeber:
Sendet Tabelle D, Taste 1 alle 36.0 s
Transponder: Alle deaktiviert



gruss thomas (der immer noch auf suche nach t-port und p-port belegung ist, und auch noch nen modul zum basteln braucht.)javascriptseticon("icon/icon07.gif")
javascriptseticon("icon/icon07.gif")
lg Thomas

Benutzeravatar

Niko
Moderator
Moderator
Beiträge: 2143
Registriert: Di 7. Aug 2007, 17:37
Danksagung erhalten: 2 Mal

#64 RE: i-port Lichtsensor eigenbau

Beitragvon Niko » Di 6. Mai 2008, 18:51

Hallo Thomas,

da ich mich nun auch ans Basteln machen will (Dein Lichtsensor zum Selbstbauen ist genial und insbesondere bei vorhandenen Bauteilen aus der Bastelkiste preislich einfach nicht zu schlagen, trotz des dann für andere Sensoren "blockierten" I-Ports), hätte ich mal ein paar Fragen an Dich und die Runde.

[zitat](habe die sensoren in einige verschieden alte osram-gehäuse eingebaut)[/zitat]Wie sehen die aus? Hast Du (oder Deine Tester) Fotos davon?

Ich bin noch am überlegen, ob für den Außensensor die Elektronik im Warmen und Trockenen bleibt (also in einer Verteilung, der LDR würde mit langem Kabel angeschlossen), oder ob LDR und restliche Elektronik zusammen in ein witterungsbeständiges Gehäuse kommen.

Anstelle einer Platine wollte ich eine IC-Fassung verwenden und die Bauteile aus der Bastelkiste direkt dranlöten. Nun suche ich ein kleines und günstiges Zuhause für diesen Drahtigel. Dachte schon an ein gekürztes Verpackungsröhrchen für Vitamintabletten aus dem Supermarkt. Sieht ja nachher keiner, und treibt den bisherigen Preis (nur ein bisschen Strom für den Lötkolben) nicht in die Höhe. Habt Ihr vielleicht noch Ideen?

Und wie sieht es mit einem geeigneten Montageort für den LDR aus, wenn dieser Sonne von hell unterscheiden soll (wo die Sonne ins Haus scheint, kann man ja grob an der Uhrzeit festmachen)?

Da ich einen ganz anderen LDR mit höheren Widerstandswerten verwende (war halt gerade in der Bastelkiste), muss ich insbesondere C2 deutlich anpassen. Damit der Sensor das gesamte Spektrum abdecken kann (von Sonne bis dunkel), könnte man ja das Widerstandsverhältnis dunkel:sonnig durch Parallelschalten eines Widerstandes zum LDR verringern. Dann ist natürlich die Linearität des Sensors hin, aber wenn die Schwellwerte ohnehin "nach Augenmaß" gesetzt werden, sollte das ja nicht weiter stören.

Schöne Grüße
Niko, der für außen schon den freien I-Port hat, aber noch keinen fertig gelöteten Sensor


Johannes
Dr. Forum
Dr. Forum
Beiträge: 707
Registriert: Sa 3. Dez 2005, 17:24

#65 RE: i-port Lichtsensor eigenbau

Beitragvon Johannes » Di 6. Mai 2008, 19:12

[zitat]Original von Niko
Nun suche ich ein kleines und günstiges Zuhause für diesen Drahtigel. Dachte schon an ein gekürztes Verpackungsröhrchen für Vitamintabletten aus dem Supermarkt.[/zitat]
Das wird nicht lange halten. Die Sonneneinstrahlung macht die bei diesen Verpackungen verwendeten Kunststoffe sehr schnell brüchig, so daß dann Wasser eintritt. Besser ein für diesen Verwendungszweck vorgesehenes Elektronik-Kistchen mit Stopfbuchse kaufen.

Grüße, Johannes

Benutzeravatar

Themenersteller
Thomas
Alleswisser
Alleswisser
Beiträge: 5699
Registriert: Mo 21. Apr 2008, 20:03
Hat sich bedankt: 16 Mal
Danksagung erhalten: 10 Mal
Kontaktdaten:

#66 RE: i-port Lichtsensor eigenbau

Beitragvon Thomas » Di 6. Mai 2008, 19:25

Hallo niko,

das ist nicht schlecht : "Verpackungsröhrchen für Vitamintabletten", mach die kappe aber aus plexiglass, sonst ist immer dunkel.

scherz beiseite,

ich habe den ldr in ein osram-gehäuse mit einer schraubabdeckung die aus durchsichtigem plastik ist, verbaut (einen hat florian und einen hab ich)
sieht dann aus wie "Verpackungsröhrchen für Vitamintabletten mit einbauverschraubung "
(konnte ich mir nicht verkneifen, den spruch)

den anderen hab ich in einen aufputz-gehäuse von osram verbaut. (hat uwe)

leider habe ich im moment keine möglichkeit bilder zu machen. (digi-cam im a.... äh hin !)

und nochwas, der ldr hat ne log-kennlinie (werte im hellen ändern sich halt minimal)

den sensor habe ich auf ca 1,5 x 4 cm auf lochrasterplatte aufgebaut und mit nem stecher direkt an den i-port angeschlossen. ( bei florian und mir mit ca 3 mtr kabel, uwe hat leider nur nen 20cm flachbandkabel dran, mangels kabel, da alles schnell am wochenende sa-so aufgebaut)

gruss thomas ( dessen programm für den eigenbausensor leider immer noch fehlerhaft ist )
lg Thomas

Benutzeravatar

Niko
Moderator
Moderator
Beiträge: 2143
Registriert: Di 7. Aug 2007, 17:37
Danksagung erhalten: 2 Mal

#67 RE: i-port Lichtsensor eigenbau

Beitragvon Niko » Mi 7. Mai 2008, 18:37

Hallo,

[zitat]Original von Johannes
Das wird nicht lange halten. Die Sonneneinstrahlung macht die bei diesen Verpackungen verwendeten Kunststoffe sehr schnell brüchig, so daß dann Wasser eintritt. Besser ein für diesen Verwendungszweck vorgesehenes Elektronik-Kistchen mit Stopfbuchse kaufen.[/zitat]
Guter Hinweis. Du bringst mich da aber auf eine Idee, da werde ich nochmal tiefer in der Bastelkiste graben...

[zitat]Original von lma
sieht dann aus wie "Verpackungsröhrchen für Vitamintabletten mit einbauverschraubung "
(konnte ich mir nicht verkneifen, den spruch) [/zitat]
Danke für die bildliche Beschreibung, jetzt kann ich mir das sehr gut vorstellen :-O

[zitat]und nochwas, der ldr hat ne log-kennlinie (werte im hellen ändern sich halt minimal)[/zitat]
Da hast Du natürlich recht. Ich habe mir die Kennlinien nur flüchtig angesehen und bin prompt auf den alten Physiker-Trick reingefallen: einfach die Achseneinteilung so wählen, dass die Messwerte auf der gewünschten Gerade liegen.

Inzwischen habe ich den Drahtigel aufgebaut und ihn provisorisch in ein Glasgehäuse gesetzt. Im Wintergarten war halt gerade noch ein gut erreichbarer I-Port frei :-) Funktioniert auf Anhieb, jetzt kommt die Programmierung dran, dann noch das Feintuning an den Bauteilen. Nochmal vielen Dank für Deine geniale Idee!

Schöne Grüße
Niko, der die Gehäusesuche erst mal verschoben hat

Benutzeravatar

Themenersteller
Thomas
Alleswisser
Alleswisser
Beiträge: 5699
Registriert: Mo 21. Apr 2008, 20:03
Hat sich bedankt: 16 Mal
Danksagung erhalten: 10 Mal
Kontaktdaten:

#68 RE: i-port Lichtsensor eigenbau

Beitragvon Thomas » Mi 7. Mai 2008, 21:09

Hallo Niko,

schön das es geklappt hat.

habe heute noch nen trick probiert, ldr mir 10 mtr kabel von der platine entfernt, in ein lichtdichtes gehäuse eingeklebt und mit einem ca 4 cm langen plexiglasstab (rund 5mm) der nach aussen geht, verbunden.

das ganze wasserdicht mit heisskleber eingepackt. ( meine w-lan antennen, auch mit heisskleber eingedichtet laufen schon seit 5 jahren im aussenbereich)

gehäuse : zb. kleine norka-dose

gruss thomas ( der heute keinen dummen spruch mehr draufhat)
lg Thomas

Benutzeravatar

Beleuchtfix
Administrator
Administrator
Beiträge: 5330
Registriert: Mi 10. Jan 2007, 18:49
Hat sich bedankt: 2 Mal
Danksagung erhalten: 6 Mal
Kontaktdaten:

#69 RE: i-port Lichtsensor eigenbau

Beitragvon Beleuchtfix » Mi 7. Mai 2008, 23:31

So, dann will ich endlich mal mein Bild Online stellen :-)
Gruß
Florian
Dateianhänge
132112PICT_27942.jpg
132112PICT_27942.jpg (199.96 KiB) 247 mal betrachtet
132111PICT_27939.jpg
132111PICT_27939.jpg (235.69 KiB) 247 mal betrachtet

Benutzeravatar

Uwe
...
Beiträge: 14135
Registriert: So 26. Mai 2002, 23:10
Hat sich bedankt: 12 Mal
Danksagung erhalten: 25 Mal
Kontaktdaten:

#70 RE: i-port Lichtsensor eigenbau

Beitragvon Uwe » Do 8. Mai 2008, 05:33

Ein Bild sagt mehr als tausend Worte ...

Dieses "Osram-Gehäuse" sieht für mich etwas nach einem Leuchtmelder aus.
Ich muss wohl auch mal in die Grabbelkisten abtauchen ... ;-)

Grüße, Uwe - der "seinen" Sensor wohl auch mal fotografieren muss
----------------o00o----'(_)'----o00o---------------------


Zurück zu „Hardware Eigenproduktionen“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast